FastCut — User's Guide
Welcome!
This FastCut software is the result of many years of development. It allows you to do advanced realtime video editing.
Please read this user’s guide carefully. You cannot expect to learn how to use every feature of FastCut
immediately after download. FastCut requires Mac OS X 10.4 or later.

Getting Started
After having imported the movie files by choosing 'Import…' from the 'File' menu, double click a clip
in the 'Browser' window to load it into the 'Monitor'. Here you may set in and out points, use the two
buttons in the bottom right corner. The clip segment between the in and out point is now prepared to
be included into your movie.
Drag and drop the clip from the 'Monitor' to the 'Timeline' window. Drop it onto a video track (V1, V2,
…) to include the video media of your source material and once again onto an audio track (A1, A2,
…) to include the audio media. Alternatively use the 'Insert' button (see section 4. Editing). Now,
move the playhead slider in the 'Timeline' or press the 'P' button in the 'Monitor' to switch to preview
mode. Then start your movie with the space bar… You can inspect the properties of a clip by selecting
a clip in the timeline. The ‘Inspector’ window that appears allows you to change various properties
and setup animations etc. Double-clicking a clip loads the single clip in the ‘Monitor’ window (to set
or re-set the in and out points).

1. Project
After application launch FastCut automatically creates a new project at the default location 'Movies/
My Great Movie '. Choose 'New Project…' from the 'File' menu to specify the project location on your
hard drive for your own. You may open and save a project by choosing 'Open Project…' and 'Save
Project', respectively, from the 'File' menu.

2. Preferences
Choose 'Preferences…' from the application menu. The appearing preferences dialog allows you to
specify the framesize and framerate for your movie. FastCut is ready for high definition (HD) footage.
Choose the movie size depending on your source media, not the desired output (export) size.
You may set the playback quality to low, high or dynamic. Dynamic means that FastCut automatically
changes the quality on playback depending on the current framerate for optimal playback
performance. FastCut has a highly optimized dynamic RT algorithm under the hood. You may also
setup if the 'Inspector' window should show and hide automatically (default).
You can enable motion blur by clicking on the motion blur button in the lower right corner of the
‘Monitor’ window (if you are in preview mode). The settings for motion blur can be specified in the
‘Preferences’ dialog.

3. Import
Import audio, video and still picture files by choosing 'Import…' from the 'File' menu or by directly
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dragging and dropping files from the Finder to the 'Browser' window. The files ought to be readable
by QuickTime. Note that MPEG-2 is not supported by QuickTime. But you may enable demuxed
MPEG-2 with Apple's MPEG-2 plug-in. MPEG4, H.264 and Sorenson 3 formats are not recommended
for editing on elder computers.
FastCut can import TIFF images with an alpha channel. Make sure that the TIFF files have the .tiff file
extension or HFS file type 'TIFF'. For some reasons only the TIFF still image format is supported (no
technical reasons).
In order to capture audio visual media from a camcorder or a video recorder please use a good tool
from Apple called 'QTRecorder' (or other tools from third parties). You can download it directly from:
<https://developer.apple.com/library/mac/samplecode/QTRecorder/QTRecorder.zip>.
There is no import conversion process necessary. FastCut creates reference files from the originals and
packs them into the movie project file. Your original source media is never modified.
FastCut is currently able to import files with the file extentions .mov, .mp3, .m4a,
.aac, .aiff, .mp4, .m4v, .avi, .dv, .tiff and with the HFS file type codes 'MooV', 'TIFF', 'dvc!'. If you want
to edit AVCHD files (.mts), download the free RewrapAVCHD utility and wrap your AVCHD files
with a .m4v container. This is possible without conversion, thus it is very fast (within seconds).

4. Editing
Before you add a clip to the timeline you can edit it in the 'Monitor' with the standard tools which you
can find in any QuickTime-savvy application. Hold down the shift key and move the playhead in the
'Monitor' to select a clip segment, then apply menu commands from the 'Edit' menu such as 'Cut',
Copy', 'Paste', 'Delete', 'Add', 'Trim', 'Undo' and so on to the selected clip segment. Use the 'Save Clip'
and 'Save Clip As…' commands to save your modifications. If you want to save a referenced movie
clip externally, press the 'External' button in the 'Save Clip As…' dialog.
Use the two buttons in the bottom right corner of the 'Monitor' window to set in and out points for
your clip. Now, the clip is prepared for the 'Timeline'. Drag&drop the clip from the 'Monitor' to the
'Timeline' or use the 'Insert' or 'Add' [if you hold down the shift key] button to bring the clip in the
timeline. Make sure that you have selected the right track (track bar on the left side) and positioned
the playhead slider appropriately.
Notice that the selected clip segment and the segment determined with in & out points is not the
same thing.
Notice that the 'Monitor' can be used in editing mode and in preview mode (see 6. Preview). What is
the difference between 'editing mode' and 'preview mode'? For instance in Final Cut Pro you have
two monitor windows, one for the single clips ('Viewer') and one for the whole movie composition
('Canvas'). In FastCut you have only one 'Monitor' window, but you can use it as 'Viewer' or as
'Canvas'. Use the 'P' button in the bottom right corner of the 'Monitor' window to switch from 'editing
mode' (gray 'P') to 'preview mode' (blue 'P') and vice versa. Be aware that FastCut sometimes
implicitly switches from one mode to the other. If you move the playhead slider in the 'Timeline'
window, the 'Monitor' switches to 'preview mode' (if necessary). If you double-click a single clip in
the 'Timeline' to load it into the 'Monitor' and maybe to re-set the in & out points, the 'Monitor'
switches to 'editing mode' (if necessary) automatically.
Advanced: if you drag the mouse somewhere in the timeline view while you hold down the option
key, you can move the playhead without actually dragging the playhead slider at the top of the
‘Timeline’ window. This might be useful if you have scrolled the playhead slider out of the view.

5. Timeline
The 'Timeline' window shows the movie tracks. By default the first two tracks are video tracks and
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the second two are audio tracks. In general video tracks are stacked on top of audio tracks. When you
insert a clip by drag & drop from the 'Monitor' window you, will notice that video clips are marked
blue for recognition and audio clips red. There are six different clip types.
To select multiple clips hold down the shift key. Use the 'Delete' command in the 'Edit' menu menu to
remove clips from the timeline.
Choose 'Add Video Track', 'Add Audio Track' and 'Remove Tracks…' from the 'Movie' menu to add
and remove tracks. If you have (only) one clip selected, new tracks are inserted below / above
(video / audio) the track of the selected clip. If you have multiple clips or none selected, tracks are
added above / below (video / audio) the whole track stack.
Let's assume you have put two clips on the same track and you would like to close the gap between
them. Hold down the option key while clicking in the gap. You may also click in the gap after having
chosen the 'Close Gap Before Clip…' command from the 'Movie' menu.
The snapping feature, turn it on by clicking on the snapping button next to the zoom slider, makes a
clip you move close to another clip snap. Snapping is not always desired, therefore it is turned off by
default.
In order to jump to the start or end point of the currently selected clip choose 'Goto Clip Start Point' or
'Goto Clip End Point'. The 'Move Clip(s) to Playhead' command from the 'Movie' menu moves a clip
(or several clips) to the playhead.
Most menu commands in the 'Movie' menu refer to the 'Timeline' window. Bring the 'Timeline'
window to the front if the 'Movie' menu items are disabled.
A clip in the timeline can be loaded into the 'Monitor' (editing mode) by double-clicking. The
playhead position of the clip is synchronized with the playhead of the 'Timeline' window relative to
the start point of the clip. That's a very useful feature! When you re-set the in & out point of a clip that
is already included in the timeline the clip duration will change and clips arranged behind this clip
are moved appropriately.
FastCut provides native support for fvf (fgrab video format) clips. You can insert/add screen movie
fvf files to your movie. Choose 'Insert Screen Movie…' from the 'Movie' menu.
If you hold down the shift key, every ‘Insert …’ command of the ‘Movie’ menu becomes an ‘Add …’
command. All subsequent clips won’t be moved.
You can copy a clip in the timeline by drag&drop and holding down the control key. If you hold down
the command key, the clip properties will not be copied but reset.
All actions in the timeline such as clip movement (that is changing the start point of a clip), setting in
& out point, clip insertion/remove or track insertion/remove can be undone. FastCut has unlimited
undo & redo support.

6. Preview
If you have turned on preview mode by pressing the 'P' button in the 'Monitor' for instance, then ,
what you see in the 'Monitor', is the graphical equivalent of the timeline. Single clips from the
browser list or the timeline can me loaded by double-clicking in the 'Monitor' — FastCut
automatically switches from the preview mode into editing mode (if necessary).

7. Inspector
The 'Inspector' allows you to manipulate clip properties, such as clip size or clip contrast. It shows up
automatically depending on the preferences. Choose 'Show Inspector'/'Hide Inspector' from the
'Window' menu to show/hide the 'Inspector' window manually.
The left and right arrow keys allow you to jump quickly to the previous/next keyframe of the
selected clip [shortcut works also if 'Monitor' or 'Timeline' window in front].
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The 'Inspector' gives you 100 % control for each of the various clip types. Best of all, almost all clip
parameters are animatable (with keyframes) over time, not only motion parameters, but also
parameters such as sharpness (instant feedback in the 'Monitor' even during playback).

8. Transitions
Put two clips in the timeline on the same track and close the gap between them (see section
'Timeline'). Now select both clips and choose 'Apply Transition' from the 'Movie' menu. A yellow
transition clip is created between the two source clips. Note that you need surplus frames at tail and
head of the clips, respectively, to apply a transition. Thus, set in and out points appropriately. By
default a cross fade transition is created, the most common transition type. In order to change the
transition type select the transiton and change the type in the 'Inspector' window.
The transition model decribed above is deprecated. It has been superseded by a new transtion model.
FastCut projects with old transition clips can still be opened. Since FastCut version 3.0 you can create
transitions by setting the transition property of the first source clip. The subsequent second source
clip should be placed directly after the first source clip in the timeline.

9. Filters & special FX
The 'Inspector' allows you to adjust hue, saturation, brightness, contrast and sharpness of a clip.
These filters are animatable.
You may also choose from a popup menu to apply a special effect such as the popular 'Posterize'
effect.

10. Animation
There are clip properties which are animatable over time: position, size, rotation, opacity, volume,
hue, saturation, brightness, contrast, sharpness, cropping, subdivide and title effect state. These
properties are marked in the inspector (notice the points on the right side). Use the 'Enabled' check
box in the 'Animation' section of the 'Inspector' to turn on animation. Then move the playhead slider
in the timeline to specify a point in time and press the plus button in the 'Inspector' to add a
keyframe. The point in time associated with a keyframe does not necessarily have to be between start
and end point of the clip. The keyframes are listed in a popup menu in the 'Animation' section. To set
the animatable parameters for a certain keyframe, choose the keyframe from the popup menu (the
playhead slider jumps to the keyframe in the timeline) and then set the parameters. The parameters of
frames between two keyframes are computed (linear interpolation).
IMPORTANT: When animation is enabled, animatable parameters can only be set if the playhead is
over a keyframe. Select a keyframe from the popup menu and the playhead will move (exactly) to the
keyframe.
Choosing 'Reset keyframe' from the pull-down keyframe action menu (select a keyframe first) brings
the keyframe parameters back to the settings before you enabled animation with the checkbox
'Enabled'.
If you want to save time, setup your animation by choosing 'Animation Presets…' from the 'Movie'
menu. The window that appears allows you to choose from an array of presets and allows you to
exactly determine the way these presets will be applied. Move the mouse over the controls (check
boxes) for the the different options to get tool tips that explain what the individual option does.
You may also save your own keyframe animation as preset for later reuse. Choose 'Save Animation
As…' from the 'Movie' menu. Your own animation appears in the popup list of the 'Animation
Presets' window.
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11. Wireframe mode
If you like to change the clip position and size directly with the mouse in the 'Monitor' window, turn
on 'wireframe mode' by clicking the wireframe botton in the bottom right corner of the 'Monitor'
window, select a clip in the 'Timeline' and move the playhead over the selected clip. The selected clip
gets a green wireframe which can be moved by drag&drop, resized by additionally holding down the
shift key or rotated by additionally holding down the option key. Euler angles (phi, theta, psi) set the
orientation in the 3D design space. Press '1', '2', '3' keys before the option+drag operation to choose
which Euler angle (phi, theta or psi) should be changed.

12. Masking & keying
You may attach a mask to each clip in your movie composition. FastCut uses the alpha channel
(transparency channel) information of a TIFF image to determine which pixels of the clip to mask out.
Choose 'Set…' in the 'Mask' section of the 'Inspector' to specify such a mask TIFF image. The
'Addional Material' package (separate download) contains a few sample masks.
Keying allows you to substitude a color in a video clip with a 100% transparent color. You can enable
and set up keying in the 'Inspector'.

13. Titles
FastCut has an integrated ATSUI live title editor. Simply choose 'Insert Title Clip…' from the 'Movie'
menu. Title clips are purple. When a new title clip is created FastCut automatically brings the 'Title
Editor' window to the front where you may type in your text. The title editor build into FastCut uses
the ATSUI text technology of Mac OS X. Font and style may be set individually for each letter.
Title animation FX [FX = effects] may be set up in the 'Inspector'. Note that the title size (displayed in
the title bar of the 'Title Editor' window) and the clip size (in the 'Inspector' are not identical. Set the
clip size to the title size by pressing the blue button in the section 'Title Effect'.
If you wish, choose a title animation effect and set up keyframes for the title effect state parameter.
Since version 2.1.2 FastCut has the ability to use still image clips which are bigger than the movie size
determined in the 'Preferences' dialog without quality loss. To use this feature hold down the option
key while dropping the image in the timeline. Take a look at the 'Big Title' project example which can
be found in the 'Addional Material' package.

14. 3D composition clips
FastCut version 3.1 and later allows you to create composition clips. Choose ‘Insert Composition
Clip…’ from the ‘Movie’ menu. Position this clip on top of an existing clip setup. E.g. you have
created an animation consisting of a few clips in track 1 and 2 , then you can add the composition clip
in track 3. Everything that would be displayed in the canvas without the composition clip is now
captured and shown within the rectangle of the composition clip. If you like to replace the rectangle
by a 3D model, choose one further below in the ‘Inspector’ from the popup menu.
One can also select a 3D model not only for composition clips, but also for other clip types. FastCut is
capable to read the 3D format .obj if the file is not too big.

15. Export
Choose 'Export…' from the 'File' menu to export your movie. Most QuickTime formats are supported.
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By default multi-pass H.264 is preselected in the QuickTime export dialog. Single pass H.264
encoding is faster and might be a better choice. The export dialog lets you set a output size that may
differ from the movie size set in the 'Preferences' dialog.

16. Misc
Please visit the FastCut support website at <http://www.timesforfun.de/support.html> to get free
email support and additional information (FAQ, screen movies). A shortcut paper (FastCut —
Shortcuts.pdf) is available, too. Shortcuts are handy for a variaty of editing tasks. Please consider to
print the User's Guide and the shortcut paper. Having it next to your computer might be very helpful.
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This User's Guide and the software described in it (FastCut, fgrab and
extra tools) are copyrighted with all rights reserved. This User's Guide
and the software may not be copied, in whole or in part, without written
consent of the developer (Jakob Weick), except in the normal use of the
software or to make backup copies. This exception does not allow copies to
be made for others, whether or not sold, but all material purchased (with
all backup copies) may be sold, given or loaned to another person.
You may take the software from one computer to another, but you may use the
software on only one computer at a time. A multi-user license may be
purchased to allow the software to be used on more than one computer at the
same time, including a shared-disk system. Contact the developer for more
information on multi-user licenses.
The software and the documentation is provided on an 'as is' basis, without
any warranties of any kind. You assume the entire liability for the
selection and use for the software and documentation, and the developer
shall have no liabilities for any error, malfunctions, defects or loss of
data from or relating to the use of the software and/or documentation. In
no event shall the developer's liability, if any, exceed the purchase price
paid by you for the software and documentation.
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